技術メモ【Kali Linux】満たせない依存関係というエラー

IT

こんにちは、こんばんは、パスタです!

先日Kali Linuxにおけるapt-getのメモ記事を上げたのですが、

何をしていたかというと、
仮想環境上でKali Linuxを使ってとあることをしており、その際に日本語化しようとしたら

「満たせない依存関係~」

というエラーが発生して、apt-get updateしてもupgradeしても何も解決しない・・・
ちなみに実行しようとしたコマンドは

「apt-get install task-japanese-desktop」

日本語入力を可能にしたくて実行しようとしていました。

結局どうやって解決したかというと、
依存関係の元となるパッケージ「libc6-dev」を削除して再起動したら、無事入るようになりました!

ちなみにコマンドは
「apt-get remove libc6-dev」

まぁ早い話、依存関係がどうとか言われたから、削除して入れ直したって話ですねw

ただ中には安易に削除してはマズイものもあると思うので、削除する際は注意してくださいね。

意外とググっても出てこなかったので、メモ&情報共有がてら記事にしました~
(もしかしたら実は単純なことで躓く人いないだけかも・・・)

コメント

タイトルとURLをコピーしました